Jump to content
Robalo Boating Forum

DoctorK

Members
  • Posts

    3
  • Joined

  • Last visited

Everything posted by DoctorK

  1. I was under the impression when on shore power and battery charger on, house battery would stay charged? I left my live well on overnight and came out to find it all shut down. Shore current was fine - house battery dead. I did not have other engine batteries on. Shore power switch was on, battery charger showed green and on, and voltage/current good w no faults. What am I missing? Is there an other breaker or something that prevents deck lights, and others items from running from shore power w house battery engaged?
  2. Is it possible for original Robalo owners to order replacement parts directly? I reviewed the parts list on this forum and identified the part numbers. I have no idea where to order (other than calling dealer) or how much they cost. Is there a way to save a few bucks $$$? Thanks
  3. I have a 2009 Robalo 305 purchased new in late 2008. We have been taking 6-8 inches of sea water (e.g - all my gear is submerged and or floating after a day on water) in the starboard deck/fish box every time out. Doesn't appear to matter if stbd bait well behind captains chair is running/full or not. Drain plug in deck box is tightened down, deck latch seal is in tact and clamp/latch is tight, hatch gunnel drain is clear and working. It does not appear the interior top of the fish box is affixed/caulked all the way around to the bottom of the deck. Nobody at Legendary Marine in Destin can figure out where water is coming from. This has been a chronic issue since getting the boat new. There is no leaking or issue with port deck/fish box. Has anyone experienced this with their 305 or other Robalo models? Any ideas on where this is coming form or how to fix? I have contacted the factory for help - waiting. Appreciate any insights. Thanks
×
×
  • Create New...